{"cve":"CVE-2012-3866","nvd":{"published":"2012-08-06T16:55:06.367","modified":"2026-06-16T23:44:02.593","status":"Modified","description":"lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-264"],"references":["http://lists.opensuse.org/opensuse-updates/2012-07/msg00036.html","http://puppetlabs.com/security/cve/cve-2012-3866/","http://secunia.com/advisories/50014","http://www.debian.org/security/2012/dsa-2511","http://www.ubuntu.com/usn/USN-1506-1"],"products":["puppet:puppet","puppet:puppet_enterprise","puppetlabs:puppet"],"source":"nvd","synced_at":"2026-10-19T20:24:00.973572543+00:00"},"epss":{"cve":"CVE-2012-3866","score":0.00481,"percentile":0.41494,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-8jxj-9r5f-w3m2","url":"https://osv.dev/vulnerability/GHSA-8jxj-9r5f-w3m2","summary":"Puppet allows local users to obtain sensitive configuration information","modified":"2024-11-29T05:38:59.601360Z","packages":[{"ecosystem":"RubyGems","name":"puppet","purl":"pkg:gem/puppet","ranges":[">=2.7.0 <2.7.18"],"fixed":["2.7.18"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}