{"cve":"CVE-2011-1497","nvd":{"published":"2021-10-19T14:15:08.033","modified":"2026-06-16T23:29:29.923","status":"Modified","description":"A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/rails/rails/blob/38df020c95beca7e12f0188cb7e18f3c37789e20/actionpack/CHANGELOG","https://www.openwall.com/lists/oss-security/2011/04/06/13","https://github.com/rails/rails/blob/38df020c95beca7e12f0188cb7e18f3c37789e20/actionpack/CHANGELOG","https://www.openwall.com/lists/oss-security/2011/04/06/13"],"products":["rubyonrails:rails"],"source":"nvd","synced_at":"2026-10-19T21:24:39.218183596+00:00"},"epss":{"cve":"CVE-2011-1497","score":0.01285,"percentile":0.70134,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-q58j-fmvf-9rq6","url":"https://osv.dev/vulnerability/GHSA-q58j-fmvf-9rq6","summary":"Cross site scripting in actionpack Rubygem","modified":"2025-01-20T16:25:28.794961Z","packages":[{"ecosystem":"RubyGems","name":"actionpack","purl":"pkg:gem/actionpack","ranges":[">=3.0.0.rc <3.0.6"],"fixed":["3.0.6"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}