{"cve":"CVE-2011-0528","nvd":{"published":"2014-02-17T16:55:04.787","modified":"2026-06-16T23:27:34.040","status":"Modified","description":"Puppet 2.6.0 through 2.6.3 does not properly restrict access to node resources, which allows remote authenticated Puppet nodes to read or modify the resources of other nodes via unspecified vectors.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-264"],"references":["http://www.mail-archive.com/puppet-users%40googlegroups.com/msg16429.html","http://www.openwall.com/lists/oss-security/2011/01/27/6","http://www.openwall.com/lists/oss-security/2011/01/31/5","http://www.ubuntu.com/usn/USN-1365-1","http://www.mail-archive.com/puppet-users%40googlegroups.com/msg16429.html"],"products":["puppet:puppet"],"source":"nvd","synced_at":"2026-10-19T20:32:06.812358378+00:00"},"epss":{"cve":"CVE-2011-0528","score":0.01652,"percentile":0.76544,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-9pvx-fwwh-w289","url":"https://osv.dev/vulnerability/GHSA-9pvx-fwwh-w289","summary":"Puppet does not properly restrict access to node resources","modified":"2024-12-02T05:37:56.401336Z","packages":[{"ecosystem":"RubyGems","name":"puppet","purl":"pkg:gem/puppet","ranges":[">=2.6.0 <2.6.4"],"fixed":["2.6.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}