{"cve":"CVE-2010-1330","nvd":{"published":"2012-11-23T19:55:01.273","modified":"2026-06-16T23:18:08.893","status":"Modified","description":"The regular expression engine in JRuby before 1.4.1, when $KCODE is set to 'u', does not properly handle characters immediately after a UTF-8 character, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted string.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-79"],"references":["http://rhn.redhat.com/errata/RHSA-2011-1456.html","http://secunia.com/advisories/46891","http://www.jruby.org/2010/04/26/jruby-1-4-1-xss-vulnerability.html","http://www.osvdb.org/77297","https://bugs.gentoo.org/show_bug.cgi?id=317435"],"products":["jruby:jruby"],"source":"nvd","synced_at":"2026-10-19T20:27:27.940201468+00:00"},"epss":{"cve":"CVE-2010-1330","score":0.02218,"percentile":0.82658,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-wmq2-jc9m-xp4m","url":"https://osv.dev/vulnerability/GHSA-wmq2-jc9m-xp4m","summary":"Cross-site Scripting in in JRuby","modified":"2023-11-08T03:56:55.599271Z","packages":[{"ecosystem":"Maven","name":"org.jruby:jruby-core","purl":"pkg:maven/org.jruby/jruby-core","ranges":["<1.4.1"],"fixed":["1.4.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}