{"cve":"CVE-2009-4123","nvd":{"published":"2023-12-12T16:15:07.407","modified":"2026-06-16T23:13:05.020","status":"Modified","description":"The jruby-openssl gem before 0.6 for JRuby mishandles SSL certificate validation.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-295"],"references":["http://jruby.org/2009/12/07/vulnerability-in-jruby-openssl","https://github.com/advisories/GHSA-xgv7-pqqh-h2w9","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/jruby-openssl/CVE-2009-4123.yml","https://web.archive.org/web/20101213091125/http://jruby.org/2009/12/07/vulnerability-in-jruby-openssl","http://jruby.org/2009/12/07/vulnerability-in-jruby-openssl"],"products":["jruby:jruby-openssl"],"source":"nvd","synced_at":"2026-10-19T21:42:34.585441961+00:00"},"epss":{"cve":"CVE-2009-4123","score":0.006,"percentile":0.4871,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-xgv7-pqqh-h2w9","url":"https://osv.dev/vulnerability/GHSA-xgv7-pqqh-h2w9","summary":"jruby-openssl gem for JRuby fails to do proper certificate validation","modified":"2024-02-16T08:07:53.674871Z","packages":[{"ecosystem":"RubyGems","name":"jruby-openssl","purl":"pkg:gem/jruby-openssl","ranges":["<0.6"],"fixed":["0.6"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}