{"cve":"CVE-2009-0026","nvd":{"published":"2009-01-21T20:30:00.390","modified":"2026-06-16T23:04:06.883","status":"Modified","description":"Multiple cross-site scripting (XSS) vulnerabilities in Apache Jackrabbit before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the q parameter to (1) search.jsp or (2) swr.jsp.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-79"],"references":["http://secunia.com/advisories/33576","http://securityreason.com/securityalert/4942","http://www.apache.org/dist/jackrabbit/RELEASE-NOTES-1.5.2.txt","http://www.securityfocus.com/archive/1/500196/100/0/threaded","http://www.securityfocus.com/bid/33360"],"products":["apache:jackrabbit"],"source":"nvd","synced_at":"2026-10-19T19:53:23.791937413+00:00"},"epss":{"cve":"CVE-2009-0026","score":0.26778,"percentile":0.98031,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-6fxv-38xc-h866","url":"https://osv.dev/vulnerability/GHSA-6fxv-38xc-h866","summary":"Apache Jackrabbit contains Cross-site Scripting","modified":"2024-12-08T05:30:04.137963Z","packages":[{"ecosystem":"Maven","name":"org.apache.jackrabbit:jackrabbit","purl":"pkg:maven/org.apache.jackrabbit/jackrabbit","ranges":["<1.5.2"],"fixed":["1.5.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}