{"cve":"CVE-2008-4094","nvd":{"published":"2008-09-30T17:22:09.147","modified":"2026-06-16T22:57:09.793","status":"Modified","description":"Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, ActiveSupport, ActiveResource, ActionPack, and ActionMailer.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-89"],"references":["http://blog.innerewut.de/2008/6/16/why-you-should-upgrade-to-rails-2-1","http://gist.github.com/8946","http://lists.opensuse.org/opensuse-security-announce/2008-12/msg00002.html","http://rails.lighthouseapp.com/projects/8994/tickets/288","http://rails.lighthouseapp.com/projects/8994/tickets/964"],"products":["rubyonrails:rails","rubyonrails:ruby_on_rails"],"source":"nvd","synced_at":"2026-10-19T19:52:44.811608366+00:00"},"epss":{"cve":"CVE-2008-4094","score":0.0303,"percentile":0.87485,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-xf96-32q2-9rw2","url":"https://osv.dev/vulnerability/GHSA-xf96-32q2-9rw2","summary":"Rails ActiveRecord gem vulnerable to SQL injection","modified":"2024-12-07T05:39:18.718037Z","packages":[{"ecosystem":"RubyGems","name":"activerecord","purl":"pkg:gem/activerecord","ranges":["<2.1.1"],"fixed":["2.1.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}