{"cve":"CVE-2007-3227","nvd":{"published":"2007-06-14T23:30:00.000","modified":"2026-06-16T22:41:18.630","status":"Modified","description":"Cross-site scripting (XSS) vulnerability in the to_json (ActiveRecord::Base#to_json) function in Ruby on Rails before edge 9606 allows remote attackers to inject arbitrary web script via the input values.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-79"],"references":["http://bugs.gentoo.org/show_bug.cgi?id=195315","http://dev.rubyonrails.org/ticket/8371","http://osvdb.org/36378","http://pastie.caboo.se/65550.txt","http://secunia.com/advisories/25699"],"products":["rubyonrails:rails"],"source":"nvd","synced_at":"2026-10-19T19:46:28.846926071+00:00"},"epss":{"cve":"CVE-2007-3227","score":0.03683,"percentile":0.89687,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-gm25-fpmr-43fj","url":"https://osv.dev/vulnerability/GHSA-gm25-fpmr-43fj","summary":"Moderate severity vulnerability that affects rails","modified":"2025-04-09T15:30:21.670801Z","packages":[{"ecosystem":"RubyGems","name":"rails","purl":"pkg:gem/rails","ranges":["<1.2.5"],"fixed":["1.2.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}