{"cve":"CVE-2007-1355","nvd":{"published":"2007-05-21T20:30:00.000","modified":"2026-06-16T22:37:24.947","status":"Modified","description":"Multiple cross-site scripting (XSS) vulnerabilities in the appdev/sample/web/hello.jsp example application in Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.23, and 6.0.0 through 6.0.10 allow remote attackers to inject arbitrary web script or HTML via the test parameter and unspecified vectors.","cvss_v4":null,"cvss_v3":null,"cwes":[],"references":["http://community.ca.com/blogs/casecurityresponseblog/archive/2009/01/23.aspx","http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01178795","http://lists.apple.com/archives/security-announce/2008//Jun/msg00002.html","http://osvdb.org/34875","http://rhn.redhat.com/errata/RHSA-2008-0630.html"],"products":["apache:tomcat"],"source":"nvd","synced_at":"2026-10-19T19:46:28.846926071+00:00"},"epss":{"cve":"CVE-2007-1355","score":0.58246,"percentile":0.99094,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-4c6x-gfc8-c26r","url":"https://osv.dev/vulnerability/GHSA-4c6x-gfc8-c26r","summary":"Apache Tomcat Vulnerable to Cross-Site Scripting","modified":"2025-04-09T15:27:10.009557Z","packages":[{"ecosystem":"Maven","name":"org.apache.tomcat:jsp-api","purl":"pkg:maven/org.apache.tomcat/jsp-api","ranges":[">=4.1.0 <4.1.37"],"fixed":["4.1.37"]},{"ecosystem":"Maven","name":"org.apache.tomcat:jsp-api","purl":"pkg:maven/org.apache.tomcat/jsp-api","ranges":[">=5.5.0 <5.5.24"],"fixed":["5.5.24"]},{"ecosystem":"Maven","name":"org.apache.tomcat:jsp-api","purl":"pkg:maven/org.apache.tomcat/jsp-api","ranges":[">=6.0.0 <6.0.11"],"fixed":["6.0.11"]},{"ecosystem":"Maven","name":"org.apache.tomcat:jsp-api","purl":"pkg:maven/org.apache.tomcat/jsp-api","ranges":[">=5.0.0 <=5.0.30"],"fixed":[]},{"ecosystem":"Maven","name":"org.apache.tomcat:jsp-api","purl":"pkg:maven/org.apache.tomcat/jsp-api","ranges":[">=4.0.0 <=4.0.6"],"fixed":[]},{"ecosystem":"Maven","name":"org.apache.tomcat:servlet-api","purl":"pkg:maven/org.apache.tomcat/servlet-api","ranges":[">=4.1.0 <4.1.37"],"fixed":["4.1.37"]},{"ecosystem":"Maven","name":"org.apache.tomcat:servlet-api","purl":"pkg:maven/org.apache.tomcat/servlet-api","ranges":[">=5.5.0 <5.5.24"],"fixed":["5.5.24"]},{"ecosystem":"Maven","name":"org.apache.tomcat:servlet-api","purl":"pkg:maven/org.apache.tomcat/servlet-api","ranges":[">=6.0.0 <6.0.11"],"fixed":["6.0.11"]},{"ecosystem":"Maven","name":"org.apache.tomcat:servlet-api","purl":"pkg:maven/org.apache.tomcat/servlet-api","ranges":[">=5.0.0 <=5.0.30"],"fixed":[]},{"ecosystem":"Maven","name":"org.apache.tomcat:servlet-api","purl":"pkg:maven/org.apache.tomcat/servlet-api","ranges":[">=4.0.0 <=4.0.6"],"fixed":[]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}