{"cve":"CVE-2007-0469","nvd":{"published":"2007-01-24T01:28:00.000","modified":"2026-06-16T22:35:38.173","status":"Modified","description":"The extract_files function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.","cvss_v4":null,"cvss_v3":null,"cwes":[],"references":["http://marc.info/?l=full-disclosure&m=116939816621060&w=2","http://rubyforge.org/frs/shownotes.php?release_id=9074","http://www.novell.com/linux/security/advisories/2007_4_sr.html","http://www.securityfocus.com/archive/1/458128/100/0/threaded","http://www.vupen.com/english/advisories/2007/0295"],"products":["rubyforge:rubygems"],"source":"nvd","synced_at":"2026-10-19T19:44:49.019236172+00:00"},"epss":{"cve":"CVE-2007-0469","score":0.04858,"percentile":0.92036,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-95vx-q4c2-64gr","url":"https://osv.dev/vulnerability/GHSA-95vx-q4c2-64gr","summary":"RubyGems file overwrite vulnerability","modified":"2025-04-09T15:28:46.696578Z","packages":[{"ecosystem":"RubyGems","name":"rubygems-update","purl":"pkg:gem/rubygems-update","ranges":["<0.9.1"],"fixed":["0.9.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}