{"cve":"CVE-2006-4112","nvd":{"published":"2006-08-14T21:04:00.000","modified":"2026-06-16T22:28:26.940","status":"Modified","description":"Unspecified vulnerability in the \"dependency resolution mechanism\" in Ruby on Rails 1.1.0 through 1.1.5 allows remote attackers to execute arbitrary Ruby code via a URL that is not properly handled in the routing code, which leads to a denial of service (application hang) or \"data loss,\" a different vulnerability than CVE-2006-4111.","cvss_v4":null,"cvss_v3":null,"cwes":[],"references":["http://secunia.com/advisories/21424","http://secunia.com/advisories/21466","http://secunia.com/advisories/21749","http://securitytracker.com/id?1016673","http://weblog.rubyonrails.org/2006/8/10/rails-1-1-6-backports-and-full-disclosure"],"products":["rubyonrails:rails"],"source":"nvd","synced_at":"2026-10-19T19:42:44.451428143+00:00"},"epss":{"cve":"CVE-2006-4112","score":0.03121,"percentile":0.87839,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-9wrq-xvmp-xjc8","url":"https://osv.dev/vulnerability/GHSA-9wrq-xvmp-xjc8","summary":"Rails Denial of Service vulnerability","modified":"2025-04-03T15:46:47.783301Z","packages":[{"ecosystem":"RubyGems","name":"rails","purl":"pkg:gem/rails","ranges":[">=1.1.0 <1.1.6"],"fixed":["1.1.6"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}