{"cve":"CVE-2006-4111","nvd":{"published":"2006-08-14T21:04:00.000","modified":"2026-06-16T22:28:26.800","status":"Modified","description":"Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with \"severe\" or \"serious\" impact via a File Upload request with an HTTP header that modifies the LOAD_PATH variable, a different vulnerability than CVE-2006-4112.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-94"],"references":["http://blog.koehntopp.de/archives/1367-Ruby-On-Rails-Mandatory-Mystery-Patch.html","http://secunia.com/advisories/21466","http://secunia.com/advisories/21749","http://securitytracker.com/id?1016673","http://weblog.rubyonrails.org/2006/8/9/rails-1-1-5-mandatory-security-patch-and-other-tidbits"],"products":["rubyonrails:rails","rubyonrails:ruby_on_rails"],"source":"nvd","synced_at":"2026-10-19T19:42:44.451428143+00:00"},"epss":{"cve":"CVE-2006-4111","score":0.02334,"percentile":0.83579,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-rvpq-5xqx-pfpp","url":"https://osv.dev/vulnerability/GHSA-rvpq-5xqx-pfpp","summary":"Ruby on Rails vulnerable to code injection","modified":"2025-04-03T14:58:34.698394Z","packages":[{"ecosystem":"RubyGems","name":"rails","purl":"pkg:gem/rails","ranges":[">=1.1.0 <1.1.6"],"fixed":["1.1.6"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}