{"cve":"CVE-2004-2381","nvd":{"published":"2004-12-31T05:00:00.000","modified":"2026-06-16T22:09:32.943","status":"Modified","description":"HttpRequest.java in Jetty HTTP Server before 4.2.19 allows remote attackers to cause denial of service (memory usage and application crash) via HTTP requests with a large Content-Length.","cvss_v4":null,"cvss_v3":null,"cwes":[],"references":["http://cvs.sourceforge.net/viewcvs.py/jetty/Jetty/src/org/mortbay/http/HttpRequest.java?r1=1.75&r2=1.76","http://secunia.com/advisories/11166/","http://sourceforge.net/project/shownotes.php?release_id=224743","http://www.osvdb.org/4387","http://www.securityfocus.com/bid/9917"],"products":["jetty:jetty_http_server"],"source":"nvd","synced_at":"2026-10-19T19:38:22.000386253+00:00"},"epss":{"cve":"CVE-2004-2381","score":0.01801,"percentile":0.78501,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-p5rr-q5g6-gm42","url":"https://osv.dev/vulnerability/GHSA-p5rr-q5g6-gm42","summary":"Jetty HTTP Server Denial of Service vulnerability","modified":"2024-11-28T05:30:07.803612Z","packages":[{"ecosystem":"Maven","name":"org.mortbay.jetty:jetty","purl":"pkg:maven/org.mortbay.jetty/jetty","ranges":["<4.2.19"],"fixed":["4.2.19"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}